using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img\s[\w\d\W]+?>){1,}";
string substitution = @"<div class=""some_class"">$0</div>";
string input = @"text text text text text <img scr=""kotik.jpg"" alt=""котяра""/> text text text
text text text text text <img scr=""pesik.jpg"" alt=""пёс""/><img scr=""popugaichik.jpg"" alt=""птица""/><img scr=""zmeika.jpg"" ""змея""/> text text text
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}