using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:class=""|\G(?!^))(?:(?!st)[^""])*\Kst";
string substitution = @"stx";
string input = @"foo st0 st1 st2 bar
class=""st0 st1 st2"", class=""st3 st45"", class=""st678""
baz=""st0 st1 st2""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}