re = /(?:class="|\G(?!^))(?:(?!st)[^"])*\Kst/
str = 'foo st0 st1 st2 bar
class="st0 st1 st2", class="st3 st45", class="st678"
baz="st0 st1 st2"'
subst = 'stx'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result