import Foundation
let pattern = #"(?:class="|\G(?!^))(?:(?!st)[^"])*\Kst"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
foo st0 st1 st2 bar
class="st0 st1 st2", class="st3 st45", class="st678"
baz="st0 st1 st2"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"stx"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)