import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:class=\"|\\G(?!^))(?:(?!st)[^\"])*\\Kst";
final String string = "foo st0 st1 st2 bar\n\n"
+ "class=\"st0 st1 st2\", class=\"st3 st45\", class=\"st678\"\n\n"
+ "baz=\"st0 st1 st2\"";
final String subst = "stx";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}