$re = '/(?:class="|\G(?!^))(?:(?!st)[^"])*\Kst/';
$str = 'foo st0 st1 st2 bar
class="st0 st1 st2", class="st3 st45", class="st678"
baz="st0 st1 st2"';
$subst = "stx";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;