import re
regex = re.compile(r"(?:class=\"|\G(?!^))(?:(?!st)[^\"])*\Kst")
test_str = ("foo st0 st1 st2 bar\n\n"
"class=\"st0 st1 st2\", class=\"st3 st45\", class=\"st678\"\n\n"
"baz=\"st0 st1 st2\"")
subst = "stx"
result = regex.sub(subst, test_str)
if result:
print(result)