using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9_]|_$|__|[^0-9a-z_]";
string input = @"hello
he_llo
hel_1o
he_l_lo
hel__lo
_hello
8hello
hello_
abc
_abc
1abc
abc_
abc1
ab$c";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}