re = /^[0-9_]|_$|__|[^0-9a-z_]/m
str = 'hello
he_llo
hel_1o
he_l_lo
hel__lo
_hello
8hello
hello_
abc
_abc
1abc
abc_
abc1
ab$c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end