use strict;
my $str = 'hello
he_llo
hel_1o
he_l_lo
hel__lo
_hello
8hello
hello_
abc
_abc
1abc
abc_
abc1
ab$c';
my $regex = qr/^[0-9_]|_$|__|[^0-9a-z_]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}