package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9_]|_$|__|[^0-9a-z_]`)
var str = `hello
he_llo
hel_1o
he_l_lo
hel__lo
_hello
8hello
hello_
abc
_abc
1abc
abc_
abc1
ab$c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}