// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9_]|_$|__|[^0-9a-z_]").unwrap();
let string = "hello
he_llo
hel_1o
he_l_lo
hel__lo
_hello
8hello
hello_
abc
_abc
1abc
abc_
abc1
ab$c";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}