import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{ ( (?: [^\\{\\}]* | (?R) )* ) \\}";
final String string = "{\n"
+ " Id: 1180\n"
+ " Name: \"ABCD\"\n"
+ " Type: 1\n"
+ " Json: <\"\n"
+ " Some sample data\n"
+ " \">\n"
+ "},\n"
+ "{\n"
+ " Id: 1181\n"
+ " Name: \"EFGH\"\n"
+ " Type: 4\n"
+ " More: Value\n"
+ " More: Value\n"
+ " Json: <\"\n"
+ " Some sample data \"{ with more curly braces }\" and \"{ more curly braces }\";\n"
+ " \">\n"
+ "},\n"
+ "{\n"
+ " Id: 1182\n"
+ " Name: \"IJKL\"\n"
+ " Type: 2\n"
+ " Json: <\"\n"
+ " Some sample data\n"
+ " \">\n"
+ "},";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}