# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
{ ( (?: [^{}]* | (?R) )* ) }
"""
test_str = ("{\n"
" Id: 1180\n"
" Name: \"ABCD\"\n"
" Type: 1\n"
" Json: <\"\n"
" Some sample data\n"
" \">\n"
"},\n"
"{\n"
" Id: 1181\n"
" Name: \"EFGH\"\n"
" Type: 4\n"
" More: Value\n"
" More: Value\n"
" Json: <\"\n"
" Some sample data \"{ with more curly braces }\" and \"{ more curly braces }\";\n"
" \">\n"
"},\n"
"{\n"
" Id: 1182\n"
" Name: \"IJKL\"\n"
" Type: 2\n"
" Json: <\"\n"
" Some sample data\n"
" \">\n"
"},")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.