$re = '/{ ( (?: [^{}]* | (?R) )* ) }/x';
$str = '{
Id: 1180
Name: "ABCD"
Type: 1
Json: <"
Some sample data
">
},
{
Id: 1181
Name: "EFGH"
Type: 4
More: Value
More: Value
Json: <"
Some sample data "{ with more curly braces }" and "{ more curly braces }";
">
},
{
Id: 1182
Name: "IJKL"
Type: 2
Json: <"
Some sample data
">
},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);