import Foundation
let pattern = #"{ ( (?: [^{}]* | (?R) )* ) }"#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
{
Id: 1180
Name: "ABCD"
Type: 1
Json: <"
Some sample data
">
},
{
Id: 1181
Name: "EFGH"
Type: 4
More: Value
More: Value
Json: <"
Some sample data "{ with more curly braces }" and "{ more curly braces }";
">
},
{
Id: 1182
Name: "IJKL"
Type: 2
Json: <"
Some sample data
">
},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)