use strict;
my $str = '{
Id: 1180
Name: "ABCD"
Type: 1
Json: <"
Some sample data
">
},
{
Id: 1181
Name: "EFGH"
Type: 4
More: Value
More: Value
Json: <"
Some sample data "{ with more curly braces }" and "{ more curly braces }";
">
},
{
Id: 1182
Name: "IJKL"
Type: 2
Json: <"
Some sample data
">
},';
my $regex = qr/{ ( (?: [^{}]* | (?R) )* ) }/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}