// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x){ ( (?: [^{}]* | (?R) )* ) }").unwrap();
let string = "{
Id: 1180
Name: \"ABCD\"
Type: 1
Json: <\"
Some sample data
\">
},
{
Id: 1181
Name: \"EFGH\"
Type: 4
More: Value
More: Value
Json: <\"
Some sample data \"{ with more curly braces }\" and \"{ more curly braces }\";
\">
},
{
Id: 1182
Name: \"IJKL\"
Type: 2
Json: <\"
Some sample data
\">
},";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}