using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(\s*(?P<Val>[a-zA-Z]+[0-9]*|[0-9]+|\'.*\'|\[.*\])\s*(ni|in|[*\/+-]|[=!><]=|[><])\s*((?&Val))\s*\))";
string input = @"(a in b)
(a ni b)
(a in [1,2,3])
([1,2,3] == [1,2,3])
(a == 'Ahmad Hajjar')
((a+1)==b)
(1==1)
( a == a)
(1==2)
(x1!=y)
(xa1*3)
((7*3)==21)
((17*9)!=(a+b))
((( a + b )*(c-d))==(5/2))
( a+b)
( a - b)
( a/b )
( a * b )
(ahmad>feras)
(ahmad>=feras)
(feras<ahmad)
(feras<=ahmad)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}