// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\(\s*(?P<Val>[a-zA-Z]+[0-9]*|[0-9]+|\'.*\'|\[.*\])\s*(ni|in|[*\/+-]|[=!><]=|[><])\s*((?&Val))\s*\))").unwrap();
let string = "(a in b)
(a ni b)
(a in [1,2,3])
([1,2,3] == [1,2,3])
(a == 'Ahmad Hajjar')
((a+1)==b)
(1==1)
( a == a)
(1==2)
(x1!=y)
(xa1*3)
((7*3)==21)
((17*9)!=(a+b))
((( a + b )*(c-d))==(5/2))
( a+b)
( a - b)
( a/b )
( a * b )
(ahmad>feras)
(ahmad>=feras)
(feras<ahmad)
(feras<=ahmad)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}