import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(\\s*(?P<Val>[a-zA-Z]+[0-9]*|[0-9]+|\\'.*\\'|\\[.*\\])\\s*(ni|in|[*\\/+-]|[=!><]=|[><])\\s*((?&Val))\\s*\\))";
final String string = "(a in b)\n\n"
+ "(a ni b)\n\n"
+ "(a in [1,2,3])\n\n"
+ "([1,2,3] == [1,2,3])\n\n"
+ "(a == 'Ahmad Hajjar')\n\n"
+ "((a+1)==b)\n\n"
+ "(1==1)\n\n"
+ "( a == a)\n"
+ "(1==2)\n\n"
+ "(x1!=y)\n\n"
+ "(xa1*3)\n\n"
+ "((7*3)==21)\n\n"
+ "((17*9)!=(a+b))\n\n"
+ "((( a + b )*(c-d))==(5/2))\n\n"
+ "( a+b)\n\n"
+ "( a - b)\n\n"
+ "( a/b )\n\n"
+ "( a * b )\n\n"
+ "(ahmad>feras)\n\n"
+ "(ahmad>=feras)\n\n"
+ "(feras<ahmad)\n\n"
+ "(feras<=ahmad)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}