const regex = /(\(\s*(?P<Val>[a-zA-Z]+[0-9]*|[0-9]+|\'.*\'|\[.*\])\s*(ni|in|[*\/+-]|[=!><]=|[><])\s*((?&Val))\s*\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(\\s*(?P<Val>[a-zA-Z]+[0-9]*|[0-9]+|\\\'.*\\\'|\\[.*\\])\\s*(ni|in|[*\\\/+-]|[=!><]=|[><])\\s*((?&Val))\\s*\\))', 'gm')
const str = `(a in b)
(a ni b)
(a in [1,2,3])
([1,2,3] == [1,2,3])
(a == 'Ahmad Hajjar')
((a+1)==b)
(1==1)
( a == a)
(1==2)
(x1!=y)
(xa1*3)
((7*3)==21)
((17*9)!=(a+b))
((( a + b )*(c-d))==(5/2))
( a+b)
( a - b)
( a/b )
( a * b )
(ahmad>feras)
(ahmad>=feras)
(feras<ahmad)
(feras<=ahmad)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}