use strict;
my $str = '(a in b)
(a ni b)
(a in [1,2,3])
([1,2,3] == [1,2,3])
(a == \'Ahmad Hajjar\')
((a+1)==b)
(1==1)
( a == a)
(1==2)
(x1!=y)
(xa1*3)
((7*3)==21)
((17*9)!=(a+b))
((( a + b )*(c-d))==(5/2))
( a+b)
( a - b)
( a/b )
( a * b )
(ahmad>feras)
(ahmad>=feras)
(feras<ahmad)
(feras<=ahmad)';
my $regex = qr/(\(\s*(?P<Val>[a-zA-Z]+[0-9]*|[0-9]+|\'.*\'|\[.*\])\s*(ni|in|[*\/+-]|[=!><]=|[><])\s*((?&Val))\s*\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}