# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([A-Z][A-Za-z]+) (?:([A-Z][A-Za-z.]+) )?([A-Z][A-Za-z]+)$//gm;t' <<< "FirstName M. LastName
FirstName LastName
FirstName MiddleName Lastname"