re = /^([A-Z][A-Za-z]+) (?:([A-Z][A-Za-z.]+) )?([A-Z][A-Za-z]+)$/m
str = 'FirstName M. LastName
FirstName LastName
FirstName MiddleName Lastname'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result