package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z][A-Za-z]+) (?:([A-Z][A-Za-z.]+) )?([A-Z][A-Za-z]+)$`)
var str = `FirstName M. LastName
FirstName LastName
FirstName MiddleName Lastname`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}