use strict;
my $str = 'FirstName M. LastName
FirstName LastName
FirstName MiddleName Lastname';
my $regex = qr/^([A-Z][A-Za-z]+) (?:([A-Z][A-Za-z.]+) )?([A-Z][A-Za-z]+)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";