const regex = /^([A-Z][A-Za-z]+) (?:([A-Z][A-Za-z.]+) )?([A-Z][A-Za-z]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z][A-Za-z]+) (?:([A-Z][A-Za-z.]+) )?([A-Z][A-Za-z]+)$', 'gm')
const str = `FirstName M. LastName
FirstName LastName
FirstName MiddleName Lastname`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);