$re = '/^([A-Z][A-Za-z]+) (?:([A-Z][A-Za-z.]+) )?([A-Z][A-Za-z]+)$/m';
$str = 'FirstName M. LastName
FirstName LastName
FirstName MiddleName Lastname';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;