package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(is [a-zA-Z]+)`)
var str = `Sample text:
((is hot y is dry) y is windy)
Output: [is hot , is dry , is windy]
Language: javascript`
var substitution = "$1 <-- loop over each capture instance to build your array."
fmt.Println(re.ReplaceAllString(str, substitution))
}