import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(is [a-zA-Z]+)";
final String string = "Sample text: \n"
+ "((is hot y is dry) y is windy)\n"
+ "Output: [is hot , is dry , is windy]\n"
+ " \n"
+ "Language: javascript";
final String subst = "$1 <-- loop over each capture instance to build your array.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}