const regex = /(is [a-zA-Z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(is [a-zA-Z]+)', 'g')
const str = `Sample text:
((is hot y is dry) y is windy)
Output: [is hot , is dry , is windy]
Language: javascript`;
const subst = `$1 <-- loop over each capture instance to build your array.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);