import re
regex = re.compile(r"(is [a-zA-Z]+)")
test_str = ("Sample text: \n"
"((is hot y is dry) y is windy)\n"
"Output: [is hot , is dry , is windy]\n"
" \n"
"Language: javascript")
subst = "$1 <-- loop over each capture instance to build your array."
result = regex.sub(subst, test_str)
if result:
print(result)