#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\]\w+:"
Local $sString = "[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 101.00" & @CRLF & _
"[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 100.00" & @CRLF & _
"[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 102.00" & @CRLF & _
"[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 100.00" & @CRLF & _
"[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 83.00" & @CRLF & _
"[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 75.00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")