const regex = /\]\w+:/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\]\\w+:', 'gi')
const str = `[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 101.00
[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 100.00
[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 102.00
[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 100.00
[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 83.00
[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 75.00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}