using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\]\w+:";
string input = @"[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 101.00
[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 100.00
[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 102.00
[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 100.00
[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 83.00
[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 75.00
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}