// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\]\w+:").unwrap();
let string = "[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 101.00
[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 100.00
[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 102.00
[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 100.00
[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 83.00
[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 75.00
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}