import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\]\\w+:";
final String string = "[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 101.00\n"
+ "[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 100.00\n"
+ "[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 102.00\n"
+ "[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 100.00\n"
+ "[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 83.00\n"
+ "[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 75.00\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}