$re = '/\]\w+:/i';
$str = '[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 101.00
[2020.12.06-23.00.08:662][892]LogAbilitySystem: Property Health new value is: 100.00
[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 102.00
[2020.12.06-23.00.08:663][892]LogAbilitySystem: Property Stamina new value is: 100.00
[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 83.00
[2020.12.06-23.00.08:681][893]LogAbilitySystem: Property Health new value is: 75.00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);