# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([0-9]+(?:\.[0-9]+)+)\[[0-9]+\]/\1/;t' <<< "version = 10.9.8[35]"