// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b([0-9]+(?:\.[0-9]+)+)\[[0-9]+\]").unwrap();
let string = "version = 10.9.8[35]";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}