$re = '/\b([0-9]+(?:\.[0-9]+)+)\[[0-9]+\]/';
$str = 'version = 10.9.8[35]';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;