#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b([0-9]+(?:\.[0-9]+)+)\[[0-9]+\]"
Local $sString = "version = 10.9.8[35]"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)