using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([0-9]+(?:\.[0-9]+)+)\[[0-9]+\]";
string substitution = @"\1";
string input = @"version = 10.9.8[35]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}