use strict;
my $str = 'version = 10.9.8[35]';
my $regex = qr/\b([0-9]+(?:\.[0-9]+)+)\[[0-9]+\]/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";