#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z \t]*)```([A-Za-z]*)?\n([\s\S]*?)```([A-Za-z \t]*)*$"
Local $sString = "Markdowndown code blocks work with triple `'s" & @CRLF & _
"" & @CRLF & _
"This pattern matches prefix, syntax, contents, and postfix" & @CRLF & _
"" & @CRLF & _
"Like this `\`\`\`` or "```" or ``` inline blocks are like this `code here`" & @CRLF & _
"" & @CRLF & _
"x```js" & @CRLF & _
"asdf" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"test" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"Indented" & @CRLF & _
"" & @CRLF & _
" ```" & @CRLF & _
" test" & @CRLF & _
" ```" & @CRLF & _
"" & @CRLF & _
"```js" & @CRLF & _
"xyz" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"Indented with syntax" & @CRLF & _
"" & @CRLF & _
" ```js" & @CRLF & _
" xyz" & @CRLF & _
" ```" & @CRLF & _
"" & @CRLF & _
"With code content" & @CRLF & _
"" & @CRLF & _
"```js" & @CRLF & _
"const foo = () => {}" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"Postfix" & @CRLF & _
"" & @CRLF & _
"```js" & @CRLF & _
"const foo = () => {}" & @CRLF & _
"```x" & @CRLF & _
"" & @CRLF & _
"With internal ticks" & @CRLF & _
"" & @CRLF & _
"```js" & @CRLF & _
"// comment `" & @CRLF & _
"const foo = `lol" & @CRLF & _
" cool with ticks \`\`\`" & @CRLF & _
"`" & @CRLF & _
"```"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")