$re = '/^([A-Za-z \t]*)```([A-Za-z]*)?\n([\s\S]*?)```([A-Za-z \t]*)*$/m';
$str = 'Markdowndown code blocks work with triple `\'s
This pattern matches prefix, syntax, contents, and postfix
Like this `\\`\\`\\`` or "```" or ``` inline blocks are like this `code here`
x```js
asdf
```
```
test
```
Indented
```
test
```
```js
xyz
```
Indented with syntax
```js
xyz
```
With code content
```js
const foo = () => {}
```
Postfix
```js
const foo = () => {}
```x
With internal ticks
```js
// comment `
const foo = `lol
cool with ticks \\`\\`\\`
`
```';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);