import re
regex = re.compile(r"^([A-Za-z \t]*)```([A-Za-z]*)?\n([\s\S]*?)```([A-Za-z \t]*)*$", flags=re.MULTILINE)
test_str = ("Markdowndown code blocks work with triple `'s\n\n"
"This pattern matches prefix, syntax, contents, and postfix\n\n"
"Like this `\\`\\`\\`` or \"```\" or ``` inline blocks are like this `code here`\n\n"
"x```js\n"
"asdf\n"
"```\n\n"
"```\n"
"test\n"
"```\n\n"
"Indented\n\n"
" ```\n"
" test\n"
" ```\n\n"
"```js\n"
"xyz\n"
"```\n\n"
"Indented with syntax\n\n"
" ```js\n"
" xyz\n"
" ```\n\n"
"With code content\n\n"
"```js\n"
"const foo = () => {}\n"
"```\n\n"
"Postfix\n\n"
"```js\n"
"const foo = () => {}\n"
"```x\n\n"
"With internal ticks\n\n"
"```js\n"
"// comment `\n"
"const foo = `lol\n"
" cool with ticks \\`\\`\\`\n"
"`\n"
"```")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")