import Foundation
let pattern = #"^([A-Za-z \t]*)```([A-Za-z]*)?\n([\s\S]*?)```([A-Za-z \t]*)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Markdowndown code blocks work with triple `'s
This pattern matches prefix, syntax, contents, and postfix
Like this `\`\`\`` or "```" or ``` inline blocks are like this `code here`
x```js
asdf
```
```
test
```
Indented
```
test
```
```js
xyz
```
Indented with syntax
```js
xyz
```
With code content
```js
const foo = () => {}
```
Postfix
```js
const foo = () => {}
```x
With internal ticks
```js
// comment `
const foo = `lol
cool with ticks \`\`\`
`
```
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)