// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z \t]*)```([A-Za-z]*)?\n([\s\S]*?)```([A-Za-z \t]*)*$").unwrap();
let string = "Markdowndown code blocks work with triple `'s
This pattern matches prefix, syntax, contents, and postfix
Like this `\\`\\`\\`` or \"```\" or ``` inline blocks are like this `code here`
x```js
asdf
```
```
test
```
Indented
```
test
```
```js
xyz
```
Indented with syntax
```js
xyz
```
With code content
```js
const foo = () => {}
```
Postfix
```js
const foo = () => {}
```x
With internal ticks
```js
// comment `
const foo = `lol
cool with ticks \\`\\`\\`
`
```";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}